No announcement yet.

A couple of bugs ...

  • Filter
  • Time
  • Show
Clear All
new posts

  • A couple of bugs ...

    First off, thanks for 1.6. Some very useful stuff in there.

    I've a couple of bugs to report.

    1) Engaging existing Metagrid / Keyboard Maestro actions are resulting in Metagrid and Metaserver (2.2.0) crashing - although the action itself is completed. I've tested this with a couple of actions and had the same result both times.

    2) I can't see any information in the Keyboard Maestro list of macros - nothing in either column. I've followed the procedure outlined in the PDF so the macro list should have been refreshed.

    ETA: A little more on this. It appears that only some Metagrid / Keyboard Maestro macros are causing the problem. In the cases where it's crashing there's a KM action opening another file (PDF) in OSX Preview.
    Last edited by David T; 08-03-2020, 01:28 PM. Reason: Update with more info...

  • #2
    Confirming #2 from David T's comment. Can't see any Keyboard Maestro commands at all.

    Metaserver console shows "Keyboard Maestro not detected. Macros will not be sent", though Keyboard Maestro is installed and running.

    MacOS 10.15.3


    • #3
      Thanks guys - we have started investing these issues.


      • #4
        David T Some questions:

        Re 1: What do you mean by existing KM macros - the ones you have already been triggering by keyboard shortcuts/MIDI? Can you send me an example of the macro that crashes MG as an exported KM file?

        Re 2: Confirmed. On some setups it seems that Metaserver doesn't get the appropriate privileges to access KM - Apple authorisation based on file location sucks a big time. Can you please confirm:

        1. Metaserver can control KM as illustrated on the attached screenshots.

        2. You have put Metaserver 2.2.0 in the same location where your previous Metaserver version was located.
        Attached Files


        • #5
          Re 1) Existing KM Macros are the ones that were working prior to the release of 1.6 Beta and Metaserver 2.2.0. All were being triggered by Midi on notes. I have buttons that open the Dorico Manual, Version History and Popover PDF's. All follow the same outline form - pressing any of the three results in Metagrid crashing. Here is the KM macro for the Manual.


          I have no listing for Metaserver or Keyboard Maestro in the Privacy section of Security and Privacy.

          I keep Metaserver under Applications - I've just checked back with Time Machine and there was a version there 10 days ago so I'm guessing it is in the same place.


          • #6
            OK - we have solved KM permission issues that caused Metaserver to crash and make the list of KM commands empty. Please check the new Metaserver Mac 2.2.0 (Beta 2):



            • #7
              Originally posted by Metasystem View Post
              OK - we have solved KM permission issues that caused Metaserver to crash and make the list of KM commands empty. Please check the new Metaserver Mac 2.2.0 (Beta 2):

              Keyboard Mastro actions populate and work as expected now with the new build of Metaserver and Beta 1.6 of the app. ?


              • Przemek
                Przemek commented
                Editing a comment
                Good :-). Thanks for the feedback.

            • #8
              The macros are visible for me too. The macros in post 5 continue to crash Metagrid, whether they're trigerred by Midi or through the new listings.