Announcement

Collapse
No announcement yet.

Metaserver 2.3.0 crashing on Big Sur

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Metaserver 2.3.0 crashing on Big Sur

    Click image for larger version  Name:	Screen Shot 2020-12-29 at 7.56.46 PM.png Views:	1 Size:	220.0 KB ID:	1511 Click image for larger version  Name:	Screen Shot 2020-12-29 at 7.15.26 PM.png Views:	0 Size:	797.5 KB ID:	1509 Hi there.. I keep having Metaserver 2.3.0 crash on Big Sur. When I initiate Metaserver it keeps asking for the location of Logic Pro X app, which I do not use or even have installed, as I use Cubase Pro 11.

    Also in the Metaserver "setup" on the "Files" page I cannot change the directory to cubase meta system macros. When I click on the "..." buttons to the right to select the location of the macro files, I cannot change or update the location of the system resource folder containing the newer macros.

    I have deleted Metaserver and re downloaded 2.3 hoping it would refresh, and "reset" the file location, but it keeps defaulting to the original desktop directory location for the cubase app resource xml files. Is there some system resource pref. that is saving the location that I should delete?

    On Metaserver 2.2.1 this macro file location was blank, then I added the directory location to the Metagrid App specific resource folder on my desktop, to see if that made a difference in anything. All of my current metagrid problems seem to have originated from that, but I don't know how to correct it, or reset Metaserver's "files" location. Meterserver keep becoming unresponsive and needs to force quit.

    In Cubase Pro 11 some Metagrid command buttons work for example.. "START/STOP" works but many like "RECORD' or "undo" no longer works.. So my current Metagrid workflow is completely broken.

    Thoughts??
    Last edited by Christopher Drake; 12-30-2020, 05:25 AM.

  • #2
    Thanks Christopher for the report - we are examining it at this moment and the fixes will be implemented ASAP. Will be back today with more info.

    Comment


    • #3
      Ok.. Metaserver Console shows errors when I trigger "record" "save" "undo" "delete" in my Metagrid Cubase template as "error executing Logic Pro X command" Metaserver 2.3 will then sometimes crash altogether. Click image for larger version

Name:	Screen Shot 2020-12-29 at 11.03.15 PM.png
Views:	86
Size:	1.63 MB
ID:	1518

      Comment


      • #4
        OK, that's a good lead for us

        Comment


        • Christopher Drake
          Christopher Drake commented
          Editing a comment
          Hi Przemek.. an update.. I have updated all generic remotes in Cubase 11 studio setup with the current "Metasystem_App_Specific_Resources_v1.8" xml files

          I have tested all buttons on my Metagrid Cubase template.. and ALL Cubase 11 specific macros and commands trigger correctly..

          -EXCEPT-

          UNDO, REDO, SAVE, RECORD, DELETE.. and strangely.. "HALF TEMPO" (DOUBLE TEMPO however works correctly!)

          Metaserver console shows those 5 commands as- "Error executing Logic Pro X command: @@Can't get application "Logic Pro X.app"
          Last edited by Christopher Drake; 12-30-2020, 11:27 PM.

      • #5
        Christopher Drake Thanks - we have identified the bug - it will be fixed in MG1.7.1 scheduled for early next week.

        Comment


      • #6
        Under Apple review. Thanks for your patience - we hope to have it out on Monday at the latest. Thanks for your patience.

        Comment


        • #7
          Just to confirm. Yes - crashing in Big Sur. Thanks for the soon to come.

          Comment

          Working...
          X